Show running config

What is the show running config and how this can be used to troubleshoot the network issues?

Show running config is the command that can be used to see the Cisco device configuration on the volatile ram.

Running configuration is saved in the volatile memory of the Cisco device so any power interruption or device restart will delete the running configuration.

If the running configuration is correct and we want to keep the changes even after the device restart then we have to save the configuration to the start-up config.

Show running config command is one of the best troubleshooting commands that output all configurations of the device so if we have to quickly look at different configurations then we can use this command to verify the configuration and solve the issue by correcting the configuration.

To check any particular configuration like routing, interface, etc. We have to use different commands however this single command lets us know about everything so instead of checking different services separately, we can simply use this command to check all service configurations.

This command is usually helpful while configuring or updating the device, if something is not working, before digging deeper, we can use this command to check if we have made any mistake.

As this command shows the actual commands that we have used, we can also use this command to copy all the configs of one device and paste them on the other device.

Below is the example output of the show running-config command.

Router#sh ru

Building configuration…

 

Current configuration : 786 bytes

!

version 15.1

no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

!

hostname Router

!

!

!

!

!

!

!

!

ip cef

no ipv6 cef

!

!

!

!

license udi pid CISCO2901/K9 sn FTX15246TJY-

!

!

!

!

!

!

!

!

!

!

!

spanning-tree mode pvst

!

!

!

!

!

!

interface GigabitEthernet0/0

ip address 192.168.2.1 255.255.255.0

ip access-group 1 out

duplex auto

speed auto

!

interface GigabitEthernet0/1

ip address 192.168.1.2 255.255.255.0

duplex auto

speed auto

!

interface Vlan1

no ip address

shutdown

!

router rip

version 2

network 192.168.1.0

network 192.168.2.0

!

ip classless

!

ip flow-export version 9

!

!

access-list 1 deny host 192.168.1.1

access-list 1 permit any

!

!

!

!

!

!

line con 0

!

line aux 0

!

line vty 0 4

login

!

!

!

End

On this router, we have configured routing, access list, and interfaces so we can check for any misconfiguration to troubleshoot the issue with the device.

VLAN configuration cannot be checked with this command as VLAN information is saved in the Vlan.dat file separately.

To check any specific configuration we can use the pipe symbol to filter out the output as shown below

Router#show running-config | section interface

Leave a Reply