In this lab, we will configure three Cisco routers. We will enable these routers for dynamic routing using the Rip protocol.

Configuration of RIP protocol is very easy as compared to some of the link-state routing protocols like OSPF or EIGRP however RIP protocol does not offer that many features and RIP has a very simple working mechanism. RIP protocol uses hop counts when directing the traffic in the network.

RIP protocol is still widely used due to its simplicity and it is favored in small company networks where there is a fewer number of routers used and small networks do not even need advance routing protocols as they rarely use features that are provided by the advance routing protocols while big companies with hundreds of router and complex networks use advance routing protocols as they provide more features that are required for the stability and the functioning of the big networks so at the end it comes up to the requirement of the network.

To set up routers, we will assign an IP address to the router interfaces. It’s the best practice to give a unique name to the router, as well as describing the interfaces of the routers.

To enable the routing between routers we will use a basic routing protocol called Rip. After implementing the Rip protocol on all routers, we can look into the routing table of every router to check if it has learned the routes with the help of the Rip protocol. We can check the routing table using the command ‘show IP route’.

After successful configuration of the routing protocol, we must see the routes in the routing table learned with the help of RIP and if we are unable to see the routes then we have to check the configuration and troubleshoot the issue with the configuration.

In the below image, check out the routes that are learned using RIP protocol by the router, you should also make sure that router should learn routes of all the networks in the diagram.

R is representing the RIP protocol so all the routes having R in the front are learned by the router via RIP protocol.
By default, the RIP protocol auto summarizes the routes so we have to disable the summarization on each router.

We will also disable auto summarization of the routes in the routing table by using the command ‘no auto summary’.
Also, we will set up a MOTD banner on all the routers.

 

DOWNLOAD

Lab Tasks

  1. assign IP address the router interfaces
  2. enable rip protocol and disable auto summarization
  3. set router 0 name as Arizona, router 1 as Virginia, router 2 as NY
  4. Set description of the interfaces as follow

fa 0/0 interface of router 0 – connection to headquarter

fa 0/0 of router 1 –  connection to branch 1

se 2/0 of router 1 – connection to branch 2

se 2/0 of router 2 – connection to headquarter

5. Set MOTD on all routers to —- UNAUTHORIZED ACCESS IS NOT ALLOWED —-

Lab Configuration

Task 1

router 0

Router(config)#in fa 0/0
Router(config-if)#ip add 192.168.1.1 255.255.255.0
Router(config-if)#no sh

router 1

Router(config)#in fa 0/0
Router(config-if)#ip add 192.168.1.2 255.255.255.0
Router(config-if)#no sh

Router(config-if)#in se 2/0
Router(config-if)#ip add 192.168.2.1 255.255.255.0
Router(config-if)#no sh
Router(config-if)#clock rate 56000

router 2

Router(config)#in se 2/0
Router(config-if)#ip add 192.168.2.2 255.255.255.0
Router(config-if)# no sh

Task 2

router 0

Router(config)#router rip
Router(config-router)#ver 2
Router(config-router)#network 192.168.1.0
Router(config-router)#no auto-summary

Router 1

Router(config)#router rip
Router(config-router)#ver 2
Router(config-router)#network 192.168.1.0
Router(config-router)#network 192.168.2.0
Router(config-router)#no auto-summary

router 2

Router(config)#router rip
Router(config-router)#ver 2
Router(config-router)#network 192.168.2.0
Router(config-router)#no auto-summary

Router(config)#interface fastEthernet 0/0

Router(config-if)#ip address 192.168.1.1 255.255.255.0

Router(config-if)#no shutdown

Task 3

router 0

Router(config)#hostname Arizona

router 1

Router(config)#hostname Virginia

router 2

Router(config)#hostname NY

Task 4

router 0

Router(config)#in fa 0/0

Router(config-if)#description connection to headquarter

router 1

Router(config)#in fa 0/0

Router(config-if)#description connection to branch 1

Router(config)#in se 2/0

Router(config-if)#description connection to branch 2

router 2

Router(config)#in se 2/0

Router(config-if)#description connection to headquarter

Task 5

On all routers

Router(config)#banner motd / —- UNAUTHORIZED ACCESS IS NOT ALLOWED —- /