Cisco packet tracer commands and their use
Packet tracer allows us to practice various Cisco commands through simulation. Packet tracer supports lots of commands however it does not support some commands.
Updated versions of the packet tracer support more commands so with every new release of the packet tracer, we can see more supported commands and better features however it has enough commands to prepare for CCNA certification.
To check all the commands we have to practice of real Cisco device or we can use GNS3 software which is powerful emulation software that emulates a real router. It uses a real Cisco IOS to emulate the device so we can see all the available commands on the Cisco device.
GNS3 needs more learning curve and it does not support full switch commands.
Following are the packet tracer commands that we can use to configure the network in packet tracer.
Routing commands
R1# configure terminal (enter global configuration mode)
R1(config)# hostname NAME
R1(config)# service password-encryption
R1(config)# enable secret PASSWORD
R1(config)# no ip domain-lookup
R1(config)# banner motd MESSAGE
R1(config)# line console 0
R1(config-line)# password PASSWORD
R1(config-line)# login
R1(config-line)# logging synchronous
R1(config-line)# exec-timeout 1 1
R1(config)# line vty 0 4
R1# copy running-config startup-config
Switch Commands
S1(config)# interface vlan 1
S1(config-if)# description (Anything we want)
S1(config-if)# ip address 192.168.100.50 255.255.255.0 (assign an IP address)
S1(config-if)# no shutdown
S1(config-if)# exit
S1(config)# ip default-gateway 192.168.1.1
S1(config)# enable secret SECRET
S1(config)# line vty 0 15
S1(config-line)# password PASSWORD
S1(config-line)# login
S1(config-line)# transport input telnet
VLAN commands
S1(config)# vlan 10
S1(config-vlan)# name Market
S1(config)# interface fa0/1
S1(config)# interface range fa0/1 – 20
S1(config-if)# switchport mode access
S1(config-if)# switchport access vlan 10
Above are the common commands available in the packet tracer, we can use these commands to create networks and configure devices.
Packet tracer includes lots of other commands required to prepare for the CCNA certification however for higher certification, you can try GNS3.
The packet tracer is lacking in security commands and some other advanced features like firewall, voice etc.